]> git.pld-linux.org Git - packages/libxml++2.git/blob - libxml++2.spec
- unconditional noarch subpackages
[packages/libxml++2.git] / libxml++2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C++ interface for working with XML files
6 Summary(pl.UTF-8):      Interfejs C++ do pracy z plikami XML
7 Name:           libxml++2
8 Version:        2.42.0
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libxml++/2.42/libxml++-%{version}.tar.xz
13 # Source0-md5:  1abc3b5b56bf7b3dfbe743cd1496550d
14 URL:            http://libxmlplusplus.sourceforge.net/
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  doxygen >= 1:1.8.9
18 BuildRequires:  glibmm-devel >= 2.32.0
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  libtool >= 2:2.2.6
21 BuildRequires:  libxml2-devel >= 1:2.7.7
22 BuildRequires:  mm-common >= 0.9.10
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       glibmm >= 2.32.0
28 Requires:       libxml2 >= 1:2.7.7
29 Obsoletes:      libxml++ < 3.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libxml++ is a C++ interface for the libxml XML parser library.
34
35 %description -l pl.UTF-8
36 libxml++ jest interfejsem C++ do biblioteki libxml.
37
38 %package devel
39 Summary:        Header files for libxml++
40 Summary(pl.UTF-8):      Pliki nagłówkowe do libxml++
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       glibmm-devel >= 2.32.0
44 Requires:       libstdc++-devel >= 6:4.6
45 Requires:       libxml2-devel >= 1:2.7.7
46 Obsoletes:      libxml++-devel < 3.0
47
48 %description devel
49 Header files for libxml++.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe do libxml++.
53
54 %package static
55 Summary:        Static libxml++ libraries
56 Summary(pl.UTF-8):      Biblioteka statyczna libxml++
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59 Obsoletes:      libxml++-static-devel < 3.0
60
61 %description static
62 Static libxml++ libraries.
63
64 %description static -l pl.UTF-8
65 Biblioteka statyczna libxml++.
66
67 %package apidocs
68 Summary:        libxml++ API documentation
69 Summary(pl.UTF-8):      Dokumentacja API libxml++
70 Group:          Documentation
71 Obsoletes:      libxml++-apidocs < 3.0
72 BuildArch:      noarch
73
74 %description apidocs
75 libxml++ API documentation.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API libxml++.
79
80 %package examples
81 Summary:        libxml++ - example programs
82 Summary(pl.UTF-8):      libxml++ - przykładowe programy
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Obsoletes:      libxml++-examples < 3.0
86
87 %description examples
88 libxml++ - example programs.
89
90 %description examples -l pl.UTF-8
91 libxml++ - przykładowe programy.
92
93 %prep
94 %setup -q -n libxml++-%{version}
95
96 %build
97 mm-common-prepare --copy --force
98 %{__libtoolize}
99 %{__aclocal} -I build
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --disable-silent-rules \
105         %{?with_static_libs:--enable-static}
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml++-2.6.la
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog NEWS README
128 %attr(755,root,root) %{_libdir}/libxml++-2.6.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libxml++-2.6.so.2
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libxml++-2.6.so
134 %{_libdir}/libxml++-2.6
135 %{_includedir}/libxml++-2.6
136 %{_pkgconfigdir}/libxml++-2.6.pc
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libxml++-2.6.a
142 %endif
143
144 %files apidocs
145 %defattr(644,root,root,755)
146 %{_datadir}/devhelp/books/libxml++-2.6
147 %{_docdir}/libxml++-2.6
148
149 %files examples
150 %defattr(644,root,root,755)
151 %{_examplesdir}/%{name}-%{version}
This page took 0.06504 seconds and 3 git commands to generate.